码迷,mamicode.com
首页 > 其他好文 > 详细

City Game(动态规划)

时间:2016-02-20 20:16:06      阅读:245      评论:0      收藏:0      [点我收藏+]

标签:

City Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5984    Accepted Submission(s): 2569

Problem Description
Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.
Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you‘re building stands is 3$.
Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.
 

 

Input
The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:
R – reserved unit
F – free unit
In the end of each area description there is a separating line.
 

 

Output
For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.
 

 

Sample Input
2 5 6 R F F F F F F F F F F F R R R F F F F F F F F F F F F F F F 5 5 R R R R R R R R R R R R R R R R R R R R R R R R R
 

 

Sample Output
45 0

题解:上题的强化版,dp记录的当前连续的f长度;相当于长方形的高;接下来就是上题的子问题了;

刚开始一个一个字符输入的wa了,最后改成字符串输入才对;

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
const int INF=0x3f3f3f3f;
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define PI(x) printf("%d",x)
#define SD(x,y) scanf("%lf%lf",&x,&y)
#define P_ printf(" ")
const int MAXN=1010;
typedef long long LL;
char mp[MAXN][MAXN];
int l[MAXN],r[MAXN],s[MAXN];
int dp[MAXN][MAXN];
int main(){
    int T,N,M;
    SI(T);
    char ch[5];
    while(T--){
        SI(N);SI(M);
        for(int i=1;i<=N;i++){
            for(int j=1;j<=M;j++){
                scanf("%s",ch);
                mp[i][j]=ch[0];
            }
        }
        int area=0;
        mem(dp,0);
        for(int i=1;i<=N;i++){
            s[0]=s[M+1]=-1;
            for(int j=1;j<=M;j++){
                if(mp[i][j]==F)dp[i][j]=dp[i-1][j]+1;
                s[j]=dp[i][j];
                l[j]=j;r[j]=j;
            }
            for(int j=1;j<=N;j++){
                while(s[l[j]-1]>=s[j])
                    l[j]=l[l[j]-1];
            }
            for(int j=N;j>=1;j--){
                while(s[r[j]+1]>=s[j])
                    r[j]=r[r[j]+1];
            }
            for(int j=1;j<=N;j++){
                area=max(area,s[j]*(r[j]-l[j]+1));
            }
        }
        printf("%d\n",area*3);
    }
    return 0;
}

 

City Game(动态规划)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/5203774.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!