码迷,mamicode.com
首页 > 其他好文 > 详细

C - Big Number

时间:2016-02-21 21:20:36      阅读:280      评论:0      收藏:0      [点我收藏+]

标签:

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.        
                

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.        
                

Output

The output contains the number of digits in the factorial of the integers appearing in the input.        
                

Sample Input

2 10 20
                

Sample Output

7 19
 
 
求一个数阶乘的位数  n的位数为log10(n)+1    将大数利用log变为小数直接来计算位数
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        int a;
        double b=0;
        cin>>a;
        for(int i=2;i<=a;i++){
            b+=log10((double)i);
        }
        cout<<(int)b+1<<endl;
    }
    //system("pause");
    return 0;
}

 

 
 

C - Big Number

标签:

原文地址:http://www.cnblogs.com/farewell-farewell/p/5205448.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!