码迷,mamicode.com
首页 > 其他好文 > 详细

1019

时间:2014-05-07 09:12:47      阅读:282      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   java   

bubuko.com,布布扣
Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28696    Accepted Submission(s): 10785


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
 

Sample Output
105
10296
bubuko.com,布布扣
bubuko.com,布布扣
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int cmp(int a,int b)
{
    return a<b;
}
int gcd(int a,int b)
{
    if(!b)
    return a;
    return gcd(b,a%b);
}
int LCM(int a,int b)
{
    return (a*b)/gcd(a,b);    
} 
int main()
{
    int n,i,m,mm;
    int a[100000];
    cin>>n;
    while(n--)
    {
        cin>>m;
        for(i=0;i<m;i++)
        cin>>a[i];
        sort(a,a+m,cmp);
        if(m==1)
        cout<<a[0];
        if(m>1)
        {
         mm=a[0];
         for(i=1;i<m;i++)
         {
            mm=LCM(mm,a[i]);
         }
         cout<<mm<<endl;
        }
    }
    return 0;
}
bubuko.com,布布扣

上面是我的代码 WA

下面还是我的代码 AC

bubuko.com,布布扣
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int cmp(int a,int b)
{
    return a<b;
}
int gcd(int a,int b)
{
    if(!b)
    return a;
    return gcd(b,a%b);
}
int LCM(int a,int b)
{
    return a/gcd(a,b)*b;    
} 
int main()
{
    int n,i,m,mm;
    int a[100000];
    cin>>n;
    while(n--)
    {
        cin>>m;
        for(i=0;i<m;i++)
        cin>>a[i];
        sort(a,a+m,cmp);
        if(m==1)
        cout<<a[0]<<endl;
        if(m>1)
        {
         mm=a[0];
         for(i=1;i<m;i++)
         {
            mm=LCM(mm,a[i]);
         }
         cout<<mm<<endl;
        }
    }
    return 0;
}
bubuko.com,布布扣

与上面代码不同的是,下面的代码在求最小公倍数的时候不是用的(a*b)/gcd(a,b)而是用的a/gcd(a,b)*b还有就是改正了一个格式错误:if(m==1)应该是cout<<a[0]<<endl;

第一次的代码少了endl

 

求gcd的代码比较巧妙!!

 

1019,布布扣,bubuko.com

1019

标签:des   style   blog   class   code   java   

原文地址:http://www.cnblogs.com/hezixiansheng8/p/3710437.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!