码迷,mamicode.com
首页 > 其他好文 > 详细

Error Curves(2010成都现场赛题)

时间:2014-07-25 03:22:24      阅读:312      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   strong   io   

F - Error Curves

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties.

In order to test the algorithm‘s efficiency, she collects many datasets. What‘s more, each data is divided into two parts: training data and test data. She gets the parameters of the model on training data and test the model on test data.

To her surprise, she finds each dataset‘s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function ifa = 0.

 

bubuko.com,布布扣

It‘s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function‘s minimal which related to multiple quadric functions.

The new function F(x) is defined as follow:

F(x) = max(Si(x))i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function.

Josephina wonders the minimum of F(x). Unfortunately, it‘s too hard for her to solve this problem. As a super programmer, can you help her?

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n(n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000

 

简单三分。

可以证明,许多二次函数f取其最大即F(x)=max(f(x))依然为下凸函数,类似二次函数。

便可进行三分处理。

 

#include<cmath>
#include<iostream>
#include<cstdio>
#define max(x,y) ((x)<(y)?(y):(x))
double l,r,a[10005],b[10005],c[10005],mid,mmid;
int n;
double f(double x){
    double ans=-1000000000;
    for(int i=1;i<=n;i++)
        ans=max(ans,a[i]*x*x+b[i]*x+c[i]);
    return ans;
}
int main()
{
    int tt;
    scanf("%d",&tt);
    while(tt--){
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%lf%lf%lf",&a[i],&b[i],&c[i]);
        l=0;r=1000;
        while(r-l>1e-10){
            mid=(l+r)/2;
            mmid=(mid+r)/2;
            if(f(mid)<f(mmid)) r=mmid;
            else l=mid;
        }
        printf("%.4f\n",f(mid));
    }
    return 0;
}

Error Curves(2010成都现场赛题),布布扣,bubuko.com

Error Curves(2010成都现场赛题)

标签:des   style   blog   http   color   os   strong   io   

原文地址:http://www.cnblogs.com/Mathics/p/3866852.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!