码迷,mamicode.com
首页 > 其他好文 > 详细

Fibbonacci Number(杭电2070)

时间:2014-07-25 10:58:11      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:des   io   for   re   c   cti   line   amp   

 

/*Fibbonacci Number

Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.

 

Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.
 

Output
Print out the answer in a single line for each test case.
 

Sample Input
3
4
5
-1
 

Sample Output
2
3
5

HintNote:
you can use 64bit integer: __int64

*/
#include<cstdio>
#include<string.h>
__int64 s[100]={0,1,0};
int main()
{
    int n,i;
    while(~scanf("%d",&n),n!=-1)
    {
       for(i=2;i<=n;i++)
       {
            s[i]=s[i-1]+s[i-2];
        }       
        printf("%I64d\n",s[n]);
    }
    while(1);
    return 0;
}
   

Fibbonacci Number(杭电2070),布布扣,bubuko.com

Fibbonacci Number(杭电2070)

标签:des   io   for   re   c   cti   line   amp   

原文地址:http://blog.csdn.net/hdd871532887/article/details/38110643

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!