码迷,mamicode.com
首页 > 其他好文 > 详细

最长上升子序列

时间:2014-07-25 11:04:41      阅读:253      评论:0      收藏:0      [点我收藏+]

标签:des   style   os   io   for   re   c   代码   

Problem Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Author

HYNU


代码:


#include<stdio.h>
#include<malloc.h>
struct mm
{
   int a;// 输入的值 
   int b;// 存放长度 
}*x;
int main()
{
   int n,max,i,j;
   while(scanf("%d",&n)!=EOF)
   {
      x=(mm *)malloc(sizeof(mm)*n);
      for(i=0;i<n;i++)
        {                                  // 1 2 2 3 4 3 4   
           scanf("%d",&x[i].a);           // 1 7 3 5 9 4 8                                
           x[i].b=1;//每个数对应长度为一 // 1 1 1 1 1 1 1
        }   
      for(i=0;i<n;i++)
        {
           for(max=0,j=0;j<i;j++)
             {
                if(x[i].a>x[j].a&&x[j].b>max)// 找当前数(i)比其前面的数大并对应的最长的长度
                  {
                     max=x[j].b;
                  }
             }
           x[i].b=max+1;// 前面的最长长度加上本身
        }
      for(i=0,max=0;i<n;i++)
         if(max<x[i].b)max=x[i].b;// 找出最长长度 
      printf("%d\n",max);  
      free(x);
   }
   return 0;
}



最长上升子序列,布布扣,bubuko.com

最长上升子序列

标签:des   style   os   io   for   re   c   代码   

原文地址:http://blog.csdn.net/u014760201/article/details/38109737

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!