码迷,mamicode.com
首页 > 其他好文 > 详细

杭电1001

时间:2016-03-03 21:04:43      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

 

Input
The input will consist of a series of integers n, one integer per line.
 

 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

 

Sample Input
1 100
 

 

Sample Output
1 5050
 
这一题主要是考研C语言初学者如何使用循环结构,当然还要注意followed by a blank line这句话,不然是ac不了的
 

#include<stdio.h>
int main()
{
  int n,i,a;
  while(scanf("%d",&n)!=EOF)
  {
   a=0;
   for(i=1;i<=n;i++)
    a=a+i;
   printf("%d\n\n",a);// 要多空出一行
  }
  return 0;
}

  

 

杭电1001

标签:

原文地址:http://www.cnblogs.com/m1031478472/p/5239771.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!