码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1651 http://poj.org/problem?id=1651

时间:2014-07-26 01:09:36      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   strong   io   

 
http://poj.org/problem?id=1651Multiplication Puzzle
 
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6188   Accepted: 3777

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650
题意:
从中间选择一个数乘以左右俩边的数,第一个和最后一个不能选择,这个数就拿出来,怎样拿出来的顺序,使总和最小。
分析:abc sum=a*b*c;
abcd sum1=abc+acd;
sum2=bcd+abd;
sum=min(sum1,sum2)
dp[i][j]=min(dp[i][j],a[i]*a[g]*a[j]+dp[i][g]+dp[g][j]);(i<g<j)
也就是说igj,向该数列插入数字,是i和g之间或者是g和i之间。
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int dp[105][105];
int main()
{
    int i,j,k,n,a[105],g;
    while(~scanf("%d",&n))
    {
        memset(dp,0,sizeof(dp));
       for(i=0;i<n;i++)
           scanf("%d",&a[i]);
        for(k=2;k<n;k++)//保证最小有3位数。
           {
             for(i=0;i<n-k;i++)
             {
                  j=i+k;
              dp[i][j]=100000000;//求最小,初始化最大。
             for(g=i+1;g<j;g++)
                 dp[i][j]=min(dp[i][j],a[i]*a[g]*a[j]+dp[i][g]+dp[g][j]);
              }
           }
         
        printf("%d\n",dp[0][n-1]);
    }
   return 0;
}
/*
6
10 1 50 50 20 5
3650
*/

 



poj 1651 http://poj.org/problem?id=1651,布布扣,bubuko.com

poj 1651 http://poj.org/problem?id=1651

标签:des   style   blog   http   color   os   strong   io   

原文地址:http://www.cnblogs.com/cancangood/p/3868800.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!