码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1398 Square Coins(母函数)

时间:2014-07-26 01:11:36      阅读:273      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   strong   io   

 

              

                                Square Coins
              Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
                          Submit Status Practice HDU 1398

Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
 

Sample Input

2 10 30 0
 

Sample Output

1 4 27

 

#include<stdio.h>
#define MAX 310
int main(void)
{
    int n,i,j,k;
    int c1[MAX],c2[MAX];
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(i=0;i<=n;i++)
        {
            c1[i]=1;
            c2[i]=0;//当前方程
        }
        for(i=2;i*i<=n;i++){
            for(j=0;j<=n;j++){
                for(k=0;k+j<=n;k+=i*i)
                    c2[k+j]+=c1[j];//当前方程的系数 向下继承k(各种硬币直)+j
            }
            for(j=0;j<=n;j++){
                c1[j]=c2[j];
                c2[j]=0;
            }
        }
        printf("%d\n",c1[n]);
    }
    return 0;
}

 

HDU 1398 Square Coins(母函数),布布扣,bubuko.com

HDU 1398 Square Coins(母函数)

标签:des   style   blog   http   color   os   strong   io   

原文地址:http://www.cnblogs.com/woshijishu3/p/3868851.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!