码迷,mamicode.com
首页 > 其他好文 > 详细

stack 集合栈计算机 (摘)

时间:2016-03-05 16:01:09      阅读:169      评论:0      收藏:0      [点我收藏+]

标签:

有一个专门为了集合运算而设计的“集合栈”计算机。该机器有一个初始为空的栈,并且支持以下操作:
PUSH:空集“{}”入栈
DUP:把当前栈顶元素复制一份后再入栈
UNION:出栈两个集合,然后把两者的并集入栈
INTERSECT:出栈两个集合,然后把二者的交集入栈
ADD:出栈两个集合,然后把先出栈的集合加入到后出栈的集合中,把结果入栈
       每次操作后,输出栈顶集合的大小(即元素个数)。例如栈顶元素是A={ {}, {{}} }, 下一个元素是B={ {}, {{{}}} },则:
UNION操作将得到{ {}, {{}}, {{{}}} },输出3.
INTERSECT操作将得到{ {} },输出1
ADD操作将得到{ {}, {{{}}}, { {}, {{}} } },输出3.

输入不超过2000个操作

Sample Input

9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION

Sample Output

0
0
1
0
1
1
2
2
2

 

#include<iostream>
#include<string>
#include<algorithm>
#include<iterator>
#include<vector>
#include<set>
#include<map>
#include<stack>
using namespace std;
typedef set<int> Set;          
map<Set,int> IDcache;           //把集合映射成ID
vector<Set> Setcache;    
int ID(Set x)              //查找给定集合x的ID,如果找不到,分配一个新ID
{
    if(IDcache.count(x))return IDcache[x];
    Setcache.push_back(x);             //添加新集合
    return IDcache[x]=Setcache.size()-1;
}
#define ALL(x) x.begin(),x.end()
#define INS(x) inserter(x,x.begin())
int main() 
{
    stack<int> s;
    int n;
    cin>>n;
    for(int i=0;i<n;i++){
        string op;
        cin>>op;
        if(op[0]==P)s.push(ID(Set()));
        else if(op[0]==D)s.push(s.top());
        else{
            Set x1=Setcache[s.top()];          //top()取栈顶元素(但不删除)
            s.pop();                           //pop()从栈顶弹出元素即删除栈顶元素
            Set x2=Setcache[s.top()];
            s.pop();                          //取出上数倒数第二个并删除
            Set x;
            if(op[0]==U)set_union (ALL(x1),ALL(x2),INS(x));                //求并集
            if(op[0]==I)set_intersection(ALL(x1),ALL(x2),INS(x));           //求交集
            if(op[0]==A){
                x=x2;
                x.insert(ID(x1));
            }
            s.push(ID(x));
        }
        cout<<Setcache[s.top()].size()<<endl;
    }
    system("pause");
    return 0;
}

 

stack 集合栈计算机 (摘)

标签:

原文地址:http://www.cnblogs.com/farewell-farewell/p/5244840.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!