码迷,mamicode.com
首页 > 其他好文 > 详细

Risk(最短路)

时间:2016-03-05 23:39:37      阅读:290      评论:0      收藏:0      [点我收藏+]

标签:

Risk
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 2915   Accepted: 1352

Description

Risk is a board game in which several opposing players attempt to conquer the world. The gameboard consists of a world map broken up into hypothetical countries. During a player‘s turn, armies stationed in one country are only allowed to attack only countries with which they share a common border. Upon conquest of that country, the armies may move into the newly conquered country. 
During the course of play, a player often engages in a sequence of conquests with the goal of transferring a large mass of armies from some starting country to a destination country. Typically, one chooses the intervening countries so as to minimize the total number of countries that need to be conquered. Given a description of the gameboard with 20 countries each with between 1 and 19 connections to other countries, your task is to write a function that takes a starting country and a destination country and computes the minimum number of countries that must be conquered to reach the destination. You do not need to output the sequence of countries, just the number of countries to be conquered including the destination. For example, if starting and destination countries are neighbors, then your program should return one. 
The following connection diagram illustrates the first sample input. 
技术分享

Input

Input to your program will consist of a series of country configuration test sets. Each test set will consist of a board description on lines 1 through 19. The representation avoids listing every national boundary twice by only listing the fact that country I borders country J when I < J. Thus, the Ith line, where I is less than 20, contains an integer X indicating how many "higher-numbered" countries share borders with country I, then X distinct integers J greater than I and not exceeding 20, each describing a boundary between countries I and J. Line 20 of the test set contains a single integer (1 <= N <= 100) indicating the number of country pairs that follow. The next N lines each contain exactly two integers (1 <= A,B <= 20; A!=B) indicating the starting and ending countries for a possible conquest. 
There can be multiple test sets in the input file; your program should continue reading and processing until reaching the end of file. There will be at least one path between any two given countries in every country configuration. 

Output

For each input set, your program should print the following message "Test Set #T" where T is the number of the test set starting with 1. The next NT lines each will contain the result for the corresponding test in the test set - that is, the minimum number of countries to conquer. The test result line should contain the start country code A the string " to " the destination country code B ; the string ": " and a single integer indicating the minimum number of moves required to traverse from country A to country B in the test set. Following all result lines of each input set, your program should print a single blank line.

Sample Input

1 3
2 3 4
3 4 5 6
1 6
1 7
2 12 13
1 8
2 9 10
1 11
1 11
2 12 17
1 14
2 14 15
2 15 16
1 16
1 19
2 18 19
1 20
1 20
5
1 20
2 9
19 5
18 19
16 20

Sample Output

Test Set #1
1 to 20: 7
2 to 9: 5
19 to 5: 6
18 to 19: 2
16 to 20: 2
题解:很水的一道题,就是个最简单的最短路;
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
#define SI(x) scanf("%d",&x)
#define PI(x) printf("%d",x)
#define P_ printf(" ")
#define mem(x,y) memset(x,y,sizeof(x))
const int MAXN=25;
int mp[MAXN][MAXN],d[MAXN],vis[MAXN];
void dijkscra(int u){
    mem(vis,0);
    mem(d,INF);
    d[u]=0;
    while(true){
        int k=-1;
        for(int i=1;i<=20;i++){
            if(!vis[i])if(k==-1||d[i]<d[k])k=i;
        }
        if(k==-1)break;
        vis[k]=1;
        for(int i=1;i<=20;i++)
            d[i]=min(d[i],d[k]+mp[k][i]);
    }
}
int main(){
    int kase=0;
    while(1){
        mem(mp,INF);
        int x,b,a;
        for(int i=1;i<=19;i++){
            if(!~scanf("%d",&x))exit(0);
            while(x--){
                scanf("%d",&b);
                mp[i][b]=mp[b][i]=1;
            }
        }
        if(!~scanf("%d",&x))exit(0);
        printf("Test Set #%d\n",++kase);
        while(x--){
            scanf("%d%d",&a,&b);
            dijkscra(a);
            printf("%d to %d: %d\n",a,b,d[b]);
        }
        puts("");
    }
    return 0;
}

 

Risk(最短路)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/5246079.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!