码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 4876 ZCC loves cards

时间:2014-07-26 02:03:46      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   java   color   os   strong   数据   


枚举组合,在不考虑连续的情况下判断是否可以覆盖L...R,对随机数据是一个很大的减枝.

通过检测的暴力计算一遍


ZCC loves cards

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1346    Accepted Submission(s): 335


Problem Description
ZCC loves playing cards. He has n magical cards and each has a number on it. He wants to choose k cards and place them around in any order to form a circle. He can choose any several consecutive cards the number of which is m(1<=m<=k) to play a magic. The magic is simple that ZCC can get a number x=a1⊕a2...⊕am, which ai means the number on the ith card he chooses. He can play the magic infinite times, but once he begin to play the magic, he can’t change anything in the card circle including the order.
ZCC has a lucky number L. ZCC want to obtain the number L~R by using one card circle. And if he can get other numbers which aren’t in the range [L,R], it doesn’t matter. Help him to find the maximal R.
 

Input
The input contains several test cases.The first line in each case contains three integers n, k and L(k≤n≤20,1≤k≤6,1≤L≤100). The next line contains n numbers means the numbers on the n cards. The ith number a[i] satisfies 1≤a[i]≤100.
You can assume that all the test case generated randomly.
 

Output
For each test case, output the maximal number R. And if L can’t be obtained, output 0.
 

Sample Input
4 3 1 2 3 4 5
 

Sample Output
7
Hint
⊕ means xor
 

Author
镇海中学
 

Source
 

Recommend
We have carefully selected several similar problems for you:  4881 4880 4879 4878 4877 
 

Statistic | Submit | Discuss | Note



#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

int n,k,m,a[30],save[30],have[30],R,L;
bool vis[3000],cx[200];

void ckMax(int num,int sum)
{
	vis[sum]=true;
	if(num==k) return ;
	ckMax(num+1,sum^save[num]);
	ckMax(num+1,sum);
}

bool ck()
{
 	memset(vis,0,sizeof(vis));
 	ckMax(0,0);
 	for(int i=L;i<=R;i++)
 	{
 		if(vis[i]==false)	return false;
 	}
 	return true;
}

void CALU() 
{  
    if (!ck()) return;  
    for(int i=0;i<k;i++)
    	have[i]=save[i];
    do
    {
    	memset(vis,0,sizeof(vis));
    	for(int i=0;i<k;i++)
    	{
    		int x=0;
    		for(int j=0;j<k;j++)
    		{
    			x^=have[(i+j)%k];
    			vis[x]=true;	
    		}
    	}
    	for(int i=L;i<=L+k*k;i++)
    	{
    		if(vis[i]==false) break;
    		R=max(R,i);
    	}
    }while(next_permutation(have,have+k-1));
}      

void dfs(int num,int id)
{
	if(num==k)
	{
		CALU();
		return ;
	}
	for(int i=id;i<n;i++)
	{
		save[num]=a[i];
		dfs(num+1,i+1);
	}
}

int main()
{
	while(scanf("%d%d%d",&n,&k,&L)!=EOF)
	{
		R=L-1;
		for(int i=0;i<n;i++)
			scanf("%d",a+i);
		sort(a,a+n);
		dfs(0,0);
		if(R<L) printf("0\n");
		else printf("%d\n",R);
	}
	return 0;
}


HDOJ 4876 ZCC loves cards,布布扣,bubuko.com

HDOJ 4876 ZCC loves cards

标签:des   style   http   java   color   os   strong   数据   

原文地址:http://blog.csdn.net/ck_boss/article/details/38129461

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!