码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2524 并查集

时间:2014-07-26 02:34:00      阅读:246      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   2014   for   art   

Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 23580 Accepted: 11609
Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output

Case 1: 1
Case 2: 7
Hint

Huge input, scanf is recommended.
Source

Alberta Collegiate Programming Contest 2003.10.18
<span style="color:#6633ff;">***********************************************************************

     author    :   Grant Yuan
     time      :   2014.7.25
     algorithm :   并查集
     
***********************************************************************

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#define MAX 50001

using namespace std;
int ans,par[MAX];
long long n,m;
int ct=1;

void init()
{
    for(int i=0;i<=n;i++)
    {
        par[i]=i;
    }
}

int find(int x)
{
    if(x==par[x]) return x;
    else
    return par[x]=find(par[x]);
}

void unite(int x,int y)
{
    int xx,yy;
    xx=find(x);yy=find(y);
    if(yy==xx) return;
    par[yy]=xx;ans--;

}

int main()
{
    while(1){
        cin>>n>>m;int a,b;
        if(n==0&&m==0)  break;
        init();
        ans=n;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            unite(a,b);
        }
        printf("Case %d: %d\n",ct++,ans);

    }
    return 0;
}
</span>

POJ 2524 并查集,布布扣,bubuko.com

POJ 2524 并查集

标签:des   style   color   os   io   2014   for   art   

原文地址:http://blog.csdn.net/yuanchang_best/article/details/38120159

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!