标签:des http 数据 io for re c amp
/*一只小蜜蜂
Problem Description
有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。
Input
输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。
Output
对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。
Sample Input
2
1 2
3 6
Sample Output
1
3
*/#include<cstdio>
__int64 s[100]={0,1,2,0};
int main()
{
int test;
scanf("%d",&test);
while(test--)
{
int i,a,b,j,sum=0;
scanf("%d%d",&a,&b);
for(i=3;i<50;i++)
{
s[i]=s[i-1]+s[i-2];
}
printf("%I64d\n",s[b-a]);
}
//while(1);
return 0;
}
标签:des http 数据 io for re c amp
原文地址:http://blog.csdn.net/hdd871532887/article/details/38119091