码迷,mamicode.com
首页 > 其他好文 > 详细

[2016-03-11][POJ][1887][Testing the CATCHER]

时间:2016-03-11 20:48:06      阅读:280      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MSMemory Limit: 30000KB64bit IO Format: %I64d & %I64u

 Status

Description

A military contractor for the Department of Defense has just completed a series of preliminary tests for a new defensive missile called the CATCHER which is capable of intercepting multiple incoming offensive missiles. The CATCHER is supposed to be a remarkable defensive missile. It can move forward, laterally, and downward at very fast speeds, and it can intercept an offensive missile without being damaged. But it does have one major flaw. Although it can be fired to reach any initial elevation, it has no power to move higher than the last missile that it has intercepted. 

The tests which the contractor completed were computer simulations of battlefield and hostile attack conditions. Since they were only preliminary, the simulations tested only the CATCHER‘s vertical movement capability. In each simulation, the CATCHER was fired at a sequence of offensive missiles which were incoming at fixed time intervals. The only information available to the CATCHER for each incoming missile was its height at the point it could be intercepted and where it appeared in the sequence of missiles. Each incoming missile for a test run is represented in the sequence only once. 

The result of each test is reported as the sequence of incoming missiles and the total number of those missiles that are intercepted by the CATCHER in that test. 

The General Accounting Office wants to be sure that the simulation test results submitted by the military contractor are attainable, given the constraints of the CATCHER. You must write a program that takes input data representing the pattern of incoming missiles for several different tests and outputs the maximum numbers of missiles that the CATCHER can intercept for those tests. For any incoming missile in a test, the CATCHER is able to intercept it if and only if it satisfies one of these two conditions: 

The incoming missile is the first missile to be intercepted in this test. 
-or- 
The missile was fired after the last missile that was intercepted and it is not higher than the last missile which was intercepted.

Input

The input data for any test consists of a sequence of one or more non-negative integers, all of which are less than or equal to 32,767, representing the heights of the incoming missiles (the test pattern). The last number in each sequence is -1, which signifies the end of data for that particular test and is not considered to represent a missile height. The end of data for the entire input is the number -1 as the first value in a test; it is not considered to be a separate test.

Output

Output for each test consists of a test number (Test #1, Test #2, etc.) and the maximum number of incoming missiles that the CATCHER could possibly intercept for the test. That maximum number appears after an identifying message. There must be at least one blank line between output for successive data sets. 

Note: The number of missiles for any given test is not limited. If your solution is based on an inefficient algorithm, it may not execute in the allotted time. 

Sample Input

389
207
155
300
299
170
158
65
-1
23
34
21
-1
-1

Sample Output

Test #1:
  maximum possible interceptions: 6

Test #2:
  maximum possible interceptions: 2
  • 时间:2016-03-11 16:52:26 星期五
  • 题目编号:POJ 1887 Testing the CATCHER
  • 题目大意:一个导弹拦截系统,能拦截一切高度不比上一个导弹低的导弹(第一个导弹一定能拦截),给出一些列的导弹,问最多能拦截多少导弹
  • 输入:
    • 若干组数据,每组数据以-1结尾,如果一组数据以-1开头,代表输入结束
  • 输出:
    • 最大拦截的导弹数目,每组数据后面至少1行空行
  • 分析:
    • 给定一个序列,每次能拦截的导弹小于或等于上一个导弹,
    • 题目转化为,给定一列数,求最大非上升序列
  • 蒙了,导弹的数目没有设置上限,但是弄了个1W最大,水过了....
  • 每组数据之间有一个空行!!!


#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long LL;
#define CLR(x,y) memset((x),(y),sizeof((x)))
#define FOR(x,y,z) for(int (x)=(y);(x)<(z);++(x))
#define FORD(x,y,z) for(int (x)=(y);(x)>=(z);--(x))
#define FOR2(x,y,z) int (x);for((x)=(y);(x)<(z);++(x))
#define FORD2(x,y,z) int (x);for((x)=(y);(x)>=(z);--(x))




const int maxn = 10000;
int dp[maxn],a[maxn];
int main(){
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        int cntcase = 0;
        while(~scanf("%d",a) && ~a[0]){
                int n = 1;
                CLR(dp,0);
                while(~scanf("%d",a + n) && ~a[n])         ++n;
                CLR(dp,0);
                FOR(i,0,n){
                        dp[i] = 1;
                        FOR(j,0,i){
                                if(a[i] <= a[j]){
                                        dp[i] = max(dp[i],dp[j] + 1);
                                }
                        }
                }
                int ans = 0;
                FOR(i,0,n){
                        ans = max(dp[i] , ans);
                }
                printf("Test #%d:\n  maximum possible interceptions: %d\n\n",++cntcase,ans);        
        }
        return 0;
}




[2016-03-11][POJ][1887][Testing the CATCHER]

标签:

原文地址:http://www.cnblogs.com/qhy285571052/p/5267100.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!