码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1915 Knight Moves

时间:2014-07-26 17:23:32      阅读:590      评论:0      收藏:0      [点我收藏+]

标签:acm   bfs   c++   

Knight Moves

Description

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 
bubuko.com,布布扣

Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

代码:

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
struct point{
	int x;
	int y;
	int step;
}p, pp;
int d[8][2] = { { -2, 1 }, { -1, 2 }, { 1, 2 }, { 2, 1 }, { -2, -1 }, { -1, -2 }, { 1, -2 }, { 2, -1 } };
int x_1, y_1, x_2, y_2, l;
int vis[500][500];
queue<point>s;
bool isok(int x, int y)
{
	if (x >= 0 && x < l&&y >= 0 && y < l)
		return true;
	return false;
}
int bfs()
{
	if (x_1 == x_2&&y_1 == y_2)
		return 0;
	while (!s.empty())
		s.pop();
	p.x = x_1, p.y = y_1;
	p.step = 0;
	s.push(p);
	vis[x_1][y_1] = 1;
	while (!s.empty())
	{
		p = s.front();
		s.pop();
		if (p.x == x_2&&p.y == y_2)
			return p.step;
		for (int i = 0; i < 8; i++){
			int xx = p.x + d[i][0];
			int yy = p.y + d[i][1];
			if (isok(xx, yy) && !vis[xx][yy]){
				vis[xx][yy] = 1;
				pp.x = xx, pp.y = yy;
				pp.step = p.step + 1;
				s.push(pp);
			}
		}
	}
}
int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &l);
		scanf("%d%d", &x_1, &y_1);
		scanf("%d%d", &x_2, &y_2);
		memset(vis, 0, sizeof(vis));
		printf("%d\n", bfs());
	}
	return 0;
}



POJ 1915 Knight Moves,布布扣,bubuko.com

POJ 1915 Knight Moves

标签:acm   bfs   c++   

原文地址:http://blog.csdn.net/u012964281/article/details/38144731

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!