码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4185 Oil Skimming(二分匹配)

时间:2014-07-26 17:24:22      阅读:605      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   java   color   os   strong   io   

Oil Skimming

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 883    Accepted Submission(s): 374


Problem Description
Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water‘s surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.
 

Input
The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of ‘#‘ represents an oily cell, and a character of ‘.‘ represents a pure water cell.
 

Output
For each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.
 

Sample Input
1 6 ...... .##... .##... ....#. ....## ......
 

Sample Output
Case 1: 3
 

解题思路:把这些元素(#)抽象出来,然后,把这些属于两个部分的元素重新建图。

然后,求出最大匹配就OK了。可以用邻接表、或容器存储新图的信息。

#include"stdio.h"
#include"string.h"
#include"stdlib.h"
#include"vector"
using namespace std;
#define N 605
#define M 6005
vector<int>g[M];
int id[N][N],cnt;
int mark[M],link[M];
int dir[4][2]={0,1,0,-1,-1,0,1,0};
char str[N][N];
int find(int k)
{
    int i;
    for(i=0;i<g[k].size();i++)
    {
        int v=g[k][i];
        if(!mark[v])
        {
            mark[v]=1;
            if(link[v]==-1||find(link[v]))
            {
                link[v]=k;
                return 1;
            }
        }
    }
    return 0;
}
int solve(int n)
{
    int i,ans=0;
    memset(link,-1,sizeof(link));
    for(i=0;i<n;i++)
    {
        memset(mark,0,sizeof(mark));
        ans+=find(i);
    }
    return ans;
}
int main()
{
    int i,j,n,T,cas=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        cnt=0;
        for(i=0;i<n;i++)
        {
            scanf("%s",str[i]);
            for(j=0;j<n;j++)
            {
                if(str[i][j]=='#')
                {
                    id[i][j]=cnt++;
                }
            }
        }
        for(i=0;i<M;i++)
            g[i].clear();
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                int x,y,u,v,k;
                if(str[i][j]=='.')
                    continue;
                u=id[i][j];
                for(k=0;k<4;k++)
                {

                    x=dir[k][0]+i;
                    y=dir[k][1]+j;
                    if(x>=0&&x<n&&y>=0&&y<n&&str[x][y]=='#')
                    {
                        v=id[x][y];
                        g[u].push_back(v);
                        g[v].push_back(u);
                    }
                }
            }
        }
        int ans=solve(cnt);
        printf("Case %d: %d\n",cas++,ans/2);     //每条边建了两次,除以2
    }
    return 0;
}


hdu 4185 Oil Skimming(二分匹配),布布扣,bubuko.com

hdu 4185 Oil Skimming(二分匹配)

标签:des   style   http   java   color   os   strong   io   

原文地址:http://blog.csdn.net/u011721440/article/details/38144339

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!