码迷,mamicode.com
首页 > 其他好文 > 详细

Marvelous Mazes

时间:2016-03-18 21:35:11      阅读:265      评论:0      收藏:0      [点我收藏+]

标签:

F - Marvelous Mazes
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

技术分享
 

Your mission, if you decide to accept it, is to create a maze drawing program. A maze will consist of the alphabetic characters A-Z*(asterisk), and spaces.

 

Input and Output

Your program will get the information for the mazes from the input file. This file will contain lines of characters which your program must interpret to draw a maze. Each row of the maze will be described by a series of numbers and characters, where the numbers before a character tell how many times that character will be used. If there are multiple digits in a number before a character, then the number of times to repeat the character is the sum of the digits before that character.

The lowercase letter "b" will be used in the input file to represent spaces in the maze. The descriptions for different rows in the maze will be separated by an exclamation point (!) or by an end of line.

 

Descriptions for different mazes will be separated by a blank line in both input and output. The input file will be terminated by an end of file.

There is no limit to the number of rows in a maze or the number of mazes in a file, though no row will contain more than 132 characters.

Happy mazing!

 

Sample Input

 

1T1b5T!1T2b1T1b2T!1T1b1T2b2T!1T3b1T1b1T!3T3b1T!1T3b1T1b1T!5T1*1T
 
11X21b1X
4X1b1X

 

Sample Output

 

T TTTTT
T  T TT
T T  TT
T   T T
TTT   T
T   T T
TTTTT*T
 
XX   X
XXXX X
技术分享
#include<bits/stdc++.h>
using namespace std;
int main()
{
    char s[150];
    int sum=0;
    while(gets(s))
    {
        int len=strlen(s);
        for(int i=0;i<len;i++)
        {
            if(s[i]>=0&&s[i]<=9)
            {
                sum+=s[i]-0;
            }
            else if(s[i]==!)
            {
                cout<<endl;
            }
            else if(s[i]==b)
            {
                for(int j=0;j<sum;j++)
                    cout<< ;
                sum=0;
            }
            else
            {
                for(int j=0;j<sum;j++)
                {
                    cout<<s[i];
                }
                sum=0;
            }

        }
        cout<<endl;

    }
}
View Code

这里读取说的比较高级,但是用一个gets就解决了,因为它可以读取\n,水

Marvelous Mazes

标签:

原文地址:http://www.cnblogs.com/superxuezhazha/p/5293433.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!