标签:
时间限制200 ms
内存限制65536 kB
代码长度限制16000 B
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
二叉树遍历转换
#include <cstdio>
#include <stack>
using namespace std;
int preorder[35], inorder[35];
int n, preid = 0, inid = 0, cnt = 0;
int get(){
char s[10];
scanf("%s", s);
if (s[1] == ‘o‘) return -1;
int a;
scanf("%d", &a);
return a;
}
void build(int preb, int pree, int inb, int ine){
if (preb > pree) return;
int root = preorder[preb];
int inroot = inb;
while (inorder[inroot] != root) ++inroot;
build(preb+1, preb+inroot-inb, inb, inroot-1);
build(preb+inroot-inb+1, pree, inroot+1, ine);
if (cnt++ != 0) putchar(‘ ‘);
printf("%d", root);
}
int main(){
scanf("%d", &n);
stack<int> st;
for (int i = 0; i < n*2; ++i){
int a = get();
if (a != -1){
st.push(a);
preorder[preid++] = a;
}else{
inorder[inid++] = st.top();
st.pop();
}
}
build(0, n-1, 0, n-1);
return 0;
}
1086. Tree Traversals Again (25)【二叉树】——PAT (Advanced Level) Practise
标签:
原文地址:http://blog.csdn.net/xianyun2009/article/details/50927840