标签:
时间限制300 ms
内存限制65536 kB
代码长度限制16000 B
Given a sequence of positive integers and another positive integer p. The sequence is said to be a “perfect sequence” if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.
Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 10^5) is the number of integers in the sequence, and p (<= 10^9) is the parameter. In the second line there are N positive integers, each is no greater than 10^9.
Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8
排序后二分查找即可
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
int main(){
long long n, p, t;
vector<long long> v;
scanf("%lld%lld", &n, &p);
for (long long i = 0; i < n; ++i){
scanf("%lld", &t);
v.push_back(t);
}
sort(v.begin(), v.end());
int cnt = 0;
for (int i = 0; i < v.size(); ++i){
t = p * v[i];
int tmp = distance(v.begin(), upper_bound(v.begin(), v.end(), t)) - i;
cnt = max(cnt, tmp);
}
printf("%d\n", cnt);
return 0;
}
1085. Perfect Sequence (25)【二分查找】——PAT (Advanced Level) Practise
标签:
原文地址:http://blog.csdn.net/xianyun2009/article/details/50927821