码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3342 Legal or Not (判断是否存在环)

时间:2014-07-27 10:17:02      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4229    Accepted Submission(s): 1875


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it‘s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian‘s master and, at the same time, 3xian is HH‘s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B‘s master ans B is C‘s master, then A is C‘s master.
 

 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y‘s master and y is x‘s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

 

Sample Input
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

 

Sample Output
YES NO
 

 

 

       这是一道很简单的拓扑排序题吧。

       题意:让你判断这几个人的师徒关系,看是否存在不合理的关系。比如,A是B的师傅,B是C的师傅,自然A也是C的长辈吧,若存在C是A的长辈则就不合理了。

       解题思路;就是判断拓扑排序是否存在一个环。

 

贴出邻接表代码:

 

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAXN 110

struct ArcNode
{
    int to;
    struct ArcNode * next;
};

struct ArcNode * List[MAXN];
int Indegree[MAXN];
int mark;

void Topological(int n)
{
    int top = -1;
    struct ArcNode * temp;
    for(int i = 0; i<n; i++)
    {
        if(Indegree[i] == 0)
        {
            Indegree[i] = top;
            top = i;
        }
    }

    for(int i = 0; i<n; i++)
    {
        if(top == -1)     //判断是否存在环,若村证房,则跳出
        {
            mark = 1;
            break;
        }
        else
        {
            int j = top;      top = Indegree[top];
            temp = List[j];
            while(NULL != temp)
            {
                int k = temp->to;
                if(--Indegree[k] == 0)
                {
                    Indegree[k] = top;
                    top = k;
                }
                temp = temp->next;
            }
        }
    }
}

int main()
{
    int n, m, u, v;
    struct ArcNode * temp;
    while(scanf("%d%d", &n, &m)!=EOF && (n || m))
    {
        memset(List, 0, sizeof(List));
        memset(Indegree, 0, sizeof(Indegree));
        mark = 0;

        while(m--)
        {
            scanf("%d%d", &u, &v);
            Indegree[v]++;
            temp = (struct ArcNode *)malloc(sizeof(struct ArcNode));
            temp->to = v;      temp->next = NULL;
            if(List[u] == NULL)
                List[u] = temp;
            else
            {
                temp->next = List[u];
                List[u] = temp;
            }
        }

        Topological(n);

        if(mark)
            printf("NO\n");
        else
            printf("YES\n");
    }

    return 0;
}

 

hdu 3342 Legal or Not (判断是否存在环)

标签:

原文地址:http://www.cnblogs.com/fengxmx/p/3870619.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!