码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 11461 Square Numbers解题报告

时间:2016-03-20 17:55:41      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:

Discription

A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are some square numbers. Given two numbers a and b you will have to find out how many square numbers are there between a and b (inclusive).

Input

The input file contains at most 201 lines of inputs. Each line contains two integers a and b (0 < a ≤ b ≤ 100000). Input is terminated by a line containing two zeroes. This line should not be processed.

Output

For each line of input produce one line of output. This line contains an integer which denotes how many square numbers are there between a and b (inclusive).

Sample Input

1 4

1 10

0 0

Sample Output

2

3

分析

很简单的数学题吧。(第一次参加校赛做的第一个题,波澜不惊地AC了.....)

AC代码

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

int main(int argc, char const *argv[])
{
	int a, b;
	while ((scanf("%d%d", &a, &b)) == 2)
	{
		if (a == 0 && b == 0)
			break;
		printf("%d\n", (int)(floor(sqrt(b)) - ceil(sqrt(a)) + 1));
	}
}	
	

  

UVA 11461 Square Numbers解题报告

标签:

原文地址:http://www.cnblogs.com/zhaoyu1995/p/5298997.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!