码迷,mamicode.com
首页 > 其他好文 > 详细

Divide Groups 二分图的判定

时间:2016-03-20 21:29:58      阅读:284      评论:0      收藏:0      [点我收藏+]

标签:

Divide Groups

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1835    Accepted Submission(s): 657


Problem Description
技术分享

  This year is the 60th anniversary of NJUST, and to make the celebration more colorful, Tom200 is going to invite distinguished alumnus back to visit and take photos.
  After carefully planning, Tom200 announced his activity plan, one that contains two characters:
  1. Whether the effect of the event are good or bad has nothing to do with the number of people join in.
  2. The more people joining in one activity know each other, the more interesting the activity will be. Therefore, the best state is that, everyone knows each other.
  The event appeals to a great number of alumnus, and Tom200 finds that they may not know each other or may just unilaterally recognize others. To improve the activities effects, Tom200 has to divide all those who signed up into groups to take part in the activity at different time. As we know, one‘s energy is limited, and Tom200 can hold activity twice. Tom200 already knows the relationship of each two person, but he cannot divide them because the number is too large.
  Now Tom200 turns to you for help. Given the information, can you tell if it is possible to complete the dividing mission to make the two activity in best state.
 

 

Input
  The input contains several test cases, terminated by EOF.
  Each case starts with a positive integer n (2<=n<=100), which means the number of people joining in the event.
  N lines follow. The i-th line contains some integers which are the id
of students that the i-th student knows, terminated by 0. And the id starts from 1.
 

 

Output
  If divided successfully, please output "YES" in a line, else output "NO".
 

 

Sample Input
3 3 0 1 0 1 2 0
 

 

Sample Output
YES
 
#include <cstdio>
#include <cmath>
#include <vector>
#include <cstring>
#include <iostream>
using namespace std;
const int Max=111;
int G[Max][Max];
int path[Max][Max],book[Max],color[Max],book1[Max];
int n;
bool dfs(int u,int co)
{
//  cout<<u<<" "<<color[u]<<" "<<co<<endl;
  if(color[u]!=-1&&color[u]!=co) return true;
  if(color[u]==co) return false;
  color[u]=!co;
  for(int i=1;i<=n;i++)
  {
      if(u==i) continue;
      if(path[u][i]||path[i][u])
      if(book[i]) if(!dfs(i,!co)) return false;
  }
  return true;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        memset(book,0,sizeof(book));
        memset(book1,-1,sizeof(book1));
        memset(G,0,sizeof(G));
        memset(path,0,sizeof(path));
        memset(color,-1,sizeof(color));
        int tmp;
        for(int i=1;i<=n;i++)
        {
            while(scanf("%d",&tmp))
            {
                if(tmp==0) break;
                G[i][tmp]=1;
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                 if(G[i][j]!=1||G[j][i]!=1)
                 {
                     if(i==j) continue;
                     book[i]=book[j]=1;
                     path[i][j]=1;
                 }
            }
        }
        int flag=0;
        for(int i=1;i<=n;i++)
        {
          if(book[i])
           if(!dfs(i,1)) {flag=1;break;}
          memset(color,-1,sizeof(color));
        }
        if(flag) printf("NO\n");
        else     printf("YES\n");
    }
    return 0;
}

 

 

Divide Groups 二分图的判定

标签:

原文地址:http://www.cnblogs.com/zsyacm666666/p/5299477.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!