码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1273 Drainage Ditches(网络流,最大流)

时间:2014-07-27 11:17:12      阅读:255      评论:0      收藏:0      [点我收藏+]

标签:

Description

Every time it rains on Farmer John‘s fields, a pond forms over Bessie‘s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie‘s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

网络流咩,看了好久了,今天一并刷了
反复寻找源点s到汇点t之间的增广路径,若有,找出增广路径上每一段[容量-流量]的最小值d,若无,则结束。
在寻找增广路径时,可以用BFS来找,并且更新残留网络的值(涉及到反向边)。
而找到d后,则使最大流(maxflow)值加上d,更新为当前的最大流值
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<limits.h>
using namespace std;
const int maxn=220;
int n,m;
int r[maxn][maxn];
int pre[maxn];
int visit[maxn];
bool bfs(int s,int t)
{
   queue<int>q;
   memset(pre,-1,sizeof(pre));
   memset(visit,false,sizeof(visit));

   pre[s]=s;
   visit[s]=true;
   q.push(s);

   int p;
   while(!q.empty())
   {
       p=q.front();
       q.pop();
       for(int i=1;i<=n;i++)
       {
           if(r[p][i]>0&&!visit[i])
            {
                pre[i]=p;
                visit[i]=true;
                if(i==t)
                    return true;
                q.push(i);
            }
       }
   }
   return false;
}
int solve(int s,int t)
{
    int d,maxflow=0;
    while(bfs(s,t))
    {
        d=INT_MAX;
        for(int i=t;i!=s;i=pre[i])
            d=min(d,r[pre[i]][i]);
        for(int i=t;i!=s;i=pre[i])
        {
            r[pre[i]][i]-=d;
            r[i][pre[i]]+=d;
        }
        maxflow+=d;
    }
    return maxflow;
}
int main()
{
    while(cin>>m>>n)
    {
        memset(r,0,sizeof(r));
        int s,e,c;
        for(int i=0;i<m;i++)
        {
            cin>>s>>e>>c;
            r[s][e]+=c;
        }
        cout<<solve(1,n)<<endl;
    }
    return 0;
}


POJ 1273 Drainage Ditches(网络流,最大流)

标签:

原文地址:http://blog.csdn.net/u013582254/article/details/38167147

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!