标签:c++ hduj
Ignatius‘s puzzle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6222 Accepted Submission(s): 4283
Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer
a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".
Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
Output
The output contains a string "no",if you can‘t find a,or you should output a line contains the a.More details in the Sample Output.
Sample Input
Sample Output
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
int n;
while(cin>>n)
{
int m=0;
for(int i=0;i<65;i++)
{
if((18+n*i)%65==0)
{
m=i;
break;
}
}
if(m)
cout<<m<<endl;
else
cout<<"no\n";
}
return 0;
}
HDUJ 1098 Ignatius's puzzle
标签:c++ hduj
原文地址:http://blog.csdn.net/hyccfy/article/details/38151547