码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-1102 Constructing Roads ( 最小生成树 )

时间:2016-03-26 10:35:02      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1102

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

 

Sample Output
179
 
已经存在的路将村庄分成了几个集合,使用prim算法时碰到同一集合的村庄则跳过,碰到其它集合的村庄则将该集合合并。下面代码是我在VJ上A的,在HDU上需要将主程序改成循环。
 
#include<iostream>
#include<cstring>
using namespace std;

const int INF = 0x3f3f3f3f;
int n, q, ans;
int map[105][105];
int father[105];
bool flag[105];
int dis[105];

int findfather( int x ){
    while( x != father[x] )
        x = father[x];
    return x;
}

void prim(){
    ans = 0;
    memset( flag, false, sizeof( flag ) );

    for( int i = 1; i <= n; i++ )
        dis[i] = map[1][i];

    flag[1] = true;

    for( int t = 1; t < n; t++ ){
        int min = INF, mini;

        for( int i = 1; i <= n; i++){
            if( flag[i] ) continue;
            if( findfather( i ) == findfather( 1 ) ){ //使用并查集来进行区分合并
                mini = i;
                min = 0;
                break;
            }

            if( dis[i] < min ){
                min = dis[i];
                mini = i;
            }
        }

        flag[mini] = true;
        ans += min;
        father[findfather( mini )] = findfather( 1 );

        for( int j = 1; j <= n; j++ )
            if( dis[j] > map[mini][j] ){
                dis[j] = map[mini][j];
            }
    }
}

int main(){
    cin >> n;

    for( int i = 1; i <= n; i++ ){
        father[i] = i;

        for(int j = 1; j <= n; j++ )
            cin >> map[i][j];
    }

    cin >> q;
    int a,b;

    for( int i = 0; i < q; i++ ){
        cin >> a >> b;
        father[findfather( a )] = father[findfather( b )];
    }

    prim();

    cout << ans << endl;

    return 0;
}

 

HDU-1102 Constructing Roads ( 最小生成树 )

标签:

原文地址:http://www.cnblogs.com/hollowstory/p/5321523.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!