码迷,mamicode.com
首页 > 其他好文 > 详细

LightOJ - 1148 Mad Counting(坑)

时间:2016-03-28 23:15:54      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 500MS   Memory Limit: 32768KB   64bit IO Format: %lld & %llu

Status

Description

Mob was hijacked by the mayor of the Town "TruthTown". Mayor wants Mob to count the total population of the town. Now the naive approach to this problem will be counting people one by one. But as we all know Mob is a bit lazy, so he is finding some other approach so that the time will be minimized. Suddenly he found a poll result of that town where N people were asked "How many people in this town other than yourself support the same team as you in the FIFA world CUP 2010?" Now Mob wants to know if he can find the minimum possible population of the town from this statistics. Note that no people were asked the question more than once.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with an integer N (1 ≤ N ≤ 50). The next line will contain N integers denoting the replies (0 to 106) of the people.

Output

For each case, print the case number and the minimum possible population of the town.

Sample Input

2

4

1 1 2 2

1

0

Sample Output

Case 1: 5

Case 2: 1

Source

Problem Setter: Muhammad Rifayat Samee
Special Thanks: Jane Alam Jan

Status

什么鬼? 相等的话跳过只加被询问的人 ; 然后对最后相等的数进行处理相加 ;

 

#include <cstdio>
#include <algorithm>
#define N 51
int a[N];
using namespace std;
int main()
{
    int t; int Q=1; 
    scanf("%d", &t);
    while(t--)
    {
        int n;
        scanf("%d", &n);
        for(int i=0; i<n; i++)
            scanf("%d", &a[i]);
        sort(a, a+n);
        int cnt=0, sp=0;
        for(int i=0; i<n; i++)
        {
            if(i==0 || a[i]==a[i-1]) cnt++; 
            else
            {
                int k=(cnt+a[i-1]) / (a[i-1]+1);   
                sp=sp+k*(a[i-1] + 1);
                cnt=0; 
            }
        }
        sp=sp+(cnt+a[n-1])/(a[n-1]+1) *(a[n-1]+1);
        printf("Case %d: %d\n", Q++, sp);
    } 
    return 0;
}

 

 

 

LightOJ - 1148 Mad Counting(坑)

标签:

原文地址:http://www.cnblogs.com/fengshun/p/5330991.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!