码迷,mamicode.com
首页 > 其他好文 > 详细

LightOJ - 1214 Large Division(同余)

时间:2016-03-29 16:34:30      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %lld & %llu

Status

Description

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print ‘divisible‘ if a is divisible by b. Otherwise print ‘not divisible‘.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

Source

Problem Setter: Jane Alam Jan

Status

b fits into a 32 bit signed integer ? 为毛long long.

 

#include <cstdio>
#include <cstring>
int main()
{
    int t, Q=1;
    scanf("%d", &t);
    while(t--)
    {
        char num[205]; long long div;
        scanf("%s%lld", num, &div);
        int lent=strlen(num);
        long long sum=0;
        for(int i=0; i<lent; i++)
        {
            if(num[i]==-)
                continue;
            sum=sum*10+num[i]-0;
            sum=sum%div;
        }
        if(sum==0)
            printf("Case %d: divisible\n", Q++);
        else
            printf("Case %d: not divisible\n", Q++);
    }
}

 

 

 

LightOJ - 1214 Large Division(同余)

标签:

原文地址:http://www.cnblogs.com/fengshun/p/5333267.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!