码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4883 TIANKENG’s restaurant Bestcoder 2-1(模拟)

时间:2014-07-27 23:46:09      阅读:253      评论:0      收藏:0      [点我收藏+]

标签:acm   模拟   hdu   

TIANKENG’s restaurant


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 
Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 
Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 
Sample Input
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 
Sample Output
11 6


以分钟为单位 直接模拟就行了   peo[i]代表第i分钟的人  第i组人第si分钟进来 第so分钟出去  

那么j从si到so  peo[j]都加上这组的人数  最后看第几分钟人最多就是答案了

#include<cstdio>
#include<cstring>
using namespace std;
const int N = 1441;
int hi, ho, mi, mo, si, so, t, n, ans, p, peo[N];


int main()
{
    scanf ("%d", &t);
    while (t--)
    {
        scanf ("%d", &n);
        memset (peo, 0, sizeof (peo));
        for (int i = 1; i <= n; ++i)
        {
            scanf ("%d %d:%d %d:%d", &p, &hi, &mi, &ho, &mo);
            si = hi * 60 + mi;
            so = ho * 60 + mo;
            for (int j = si; j < so; ++j)
                peo[j] += p;
        }
        for (int i = ans = 1; i < N; ++i)
            if (peo[i] > ans) ans = peo[i];
        printf ("%d\n", ans);
    }
    return 0;
}



HDU 4883 TIANKENG’s restaurant Bestcoder 2-1(模拟),布布扣,bubuko.com

HDU 4883 TIANKENG’s restaurant Bestcoder 2-1(模拟)

标签:acm   模拟   hdu   

原文地址:http://blog.csdn.net/iooden/article/details/38183389

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!