标签:des style http color os strong io for
题目链接:
啊哈哈,点我点我
题目:
Radar Installation
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 52037 |
|
Accepted: 11682 |
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
Source
这道题目是贪心里面的区间选点问题。。贪心策略是:选区间的最右端的点.
思路:首先抽象出这个模型,以海岛为圆心,雷达距离为半径,求出在陆地上的区间,则雷达选在
这个区间之类那么必定能够扫描到这个海岛。。求出所有区间后,就转化成区间选点问题。。
还有就是代码中的那个标准end要用double,我wa了好久。。。
代码为:
#include<cstdio>
#include<cstdio>
#include<algorithm>
#include<cmath>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=1000+10;
struct Line
{
double le,ri;
}line[maxn];
bool cmp(Line a,Line b)
{
if(a.ri!=b.ri)
return a.ri<b.ri;
else
return a.le>b.le;
}
int main()
{
bool ok;
int u,v,cas=1;
int cnt;
double End;
int n,d;
while(~scanf("%d%d",&n,&d))
{
if(n==0&&d==0) return 0;
cnt=0;
ok=false;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&u,&v);
if(v>d)
ok=true;
else
{
line[i].le=(double)u-sqrt((double)(d*d-v*v));
line[i].ri=(double)u+sqrt((double)(d*d-v*v));
}
}
if(ok)
printf("Case %d: -1\n",cas++);
else
{
sort(line+1,line+1+n,cmp);
cnt=0;
End=-INF;
for(int i=1;i<=n;i++)
{
if(line[i].le>End)
{
cnt++;
End=line[i].ri;
}
}
printf("Case %d: %d\n",cas++,cnt);
}
}
return 0;
}
poj1328Radar Installation(贪心—区间选点),布布扣,bubuko.com
poj1328Radar Installation(贪心—区间选点)
标签:des style http color os strong io for
原文地址:http://blog.csdn.net/u014303647/article/details/38182717