标签:des style color os io for art cti
Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST ===
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein‘s secrets and
wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters,
usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing
the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then
vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."
v - w^2 + x^3 - y^4 + z^5 = target
"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode
the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn‘t exist then."
=== Op tech directive, computer division, 2002/11/02 12:30 CST ===
"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then
at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or ‘no solution‘
if there is no correct combination. Use the exact format shown below."
Sample Input
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END
Sample Output
LKEBA
YOXUZ
GHOST
no solution
我可以骂人吗,无力吐槽我自己了,AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<cmath>
using namespace std;
char str[110];
int n,len;
int num[20],numm[110];
int visit[110];
#define res(v,w,x,y,z) v-w*w+x*x*x-y*y*y*y+z*z*z*z*z
bool dfs(int step)
{
if(step==5)
{
if(res(num[0],num[1],num[2],num[3],num[4])==n)
return true;
return false;
}
for(int i=len-1;i>=0;i--)
{
if(visit[i])
continue;
visit[i]=1;
num[step]=numm[i];
if(dfs(step+1))
return true;
visit[i]=0;
}
return false;
}
int main()
{
while(~scanf("%d%s",&n,str))
{
if(n==0&&!strcmp(str,"END"))
break;
len=strlen(str);
sort(str,str+len);
for(int i=0;i<len;i++)
numm[i]=str[i]-'A'+1;
memset(visit,0,sizeof(visit));
if(dfs(0))
printf("%c%c%c%c%c\n",num[0]+'A'-1,num[1]+'A'-1,num[2]+'A'-1,num[3]+'A'-1,num[4]+'A'-1);
else
printf("no solution\n");
}
return 0;
}
另外还有一个wa的代码,你能看出来有哪些不同吗?
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<cmath>
using namespace std;
char str[110];
int n,len;
int num[20],numm[110];
int visit[110];
#define res(v,w,x,y,z) v-w*w+x*x*x-y*y*y*y+z*z*z*z*z
bool dfs(int step)
{
if(step==5)
{
if(res(num[0],num[1],num[2],num[3],num[4])==n)
return true;
return false;
}
for(int i=len-1;i>=0;i--)
{
if(visit[i])
continue;
visit[i]=1;
num[step]=numm[i];
if(dfs(step+1))
return true;
visit[i]=0;
}
return false;
}
int main()
{
while(~scanf("%d%s",&n,str))
{
if(n==0&&!strcmp(str,"END"))
break;
len=strlen(str);
for(int i=0;i<len;i++)
numm[i]=str[i]-'A'+1;
sort(str,str+len);
memset(visit,0,sizeof(visit));
if(dfs(0))
printf("%c%c%c%c%c\n",num[0]+'A'-1,num[1]+'A'-1,num[2]+'A'-1,num[3]+'A'-1,num[4]+'A'-1);
else
printf("no solution\n");
}
return 0;
}
呵呵=。=人艰不拆
HDU 1015 Safecracker,布布扣,bubuko.com
HDU 1015 Safecracker
标签:des style color os io for art cti
原文地址:http://blog.csdn.net/u013582254/article/details/38176741