码迷,mamicode.com
首页 > 其他好文 > 详细

uva 562 Dividing coins

时间:2014-07-28 00:09:10      阅读:306      评论:0      收藏:0      [点我收藏+]

标签:style   http   color   os   io   for   art   cti   

Dividing coins 

It‘s commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn‘t stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


That‘s what this whole problem is about. Not everyone is capable of seeing instantly what‘s the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It‘s not allowed to split a single coin.

Input 

A line with the number of problems n, followed by n times:

  • a line with a non negative integer m (bubuko.com,布布扣) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

Output 

The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input 

2
3
2 3 5
4
1 2 4 6

Sample Output 

0
1



Miguel A. Revilla
1998-03-10


题意:平均分成两份,使两份尽量公平,求差值。

思路:01背包,容量设成sum/2。dp[i][j]=max(dp[i-1][j],dp[i-1][j-v[i]]+v[i]).

AC代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stdlib.h>

using namespace std;

int v[105];
int dp[105][50005];

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int m;
        scanf("%d",&m);
        int sum=0;
        memset(v,0,sizeof(v));
        for(int i=1;i<=m;i++){
            scanf("%d",&v[i]);
            sum+=v[i];
            //printf("%d\n",v[i]);
        }
        sort(v,v+m);
        //for(int i=0;i<m;i++){
        //    printf("%d\n",&v[i]);
        //}
        int n;
        n=sum/2;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=m;i++){
            for(int j=0;j<=n;j++){
                dp[i][j]=dp[i-1][j];
                if(j-v[i]>=0)
                    dp[i][j]=max(dp[i][j],dp[i-1][j-v[i]]+v[i]);
            }
        }
        int a=dp[m][n];
        int b=sum-dp[m][n];
        int ans=abs(a-b);
        printf("%d\n",ans);
    }
    return 0;
}





uva 562 Dividing coins,布布扣,bubuko.com

uva 562 Dividing coins

标签:style   http   color   os   io   for   art   cti   

原文地址:http://blog.csdn.net/kimi_r_17/article/details/38172695

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!