码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 2319 Beautiful People

时间:2014-07-28 00:09:59      阅读:413      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   strong   io   for   art   

Beautiful People

Time Limit: 5 Seconds      Memory Limit: 32768 KB      Special Judge

The most prestigious sports club in one city has exactly N members. Each of its members is strong and beautiful. More precisely, i-th member of this club (members being numbered by the time they entered the club) has strength Si and beauty Bi. Since this is a very prestigious club, its members are very rich and therefore extraordinary people, so they often extremely hate each other. Strictly speaking, i-th member of the club Mr X hates j-th member of the club Mr Y if Si <= Sj and Bi >= Bj or if Si >= Sj and Bi <= Bj (if both properties of Mr X are greater then corresponding properties of Mr Y, he doesn??t even notice him, on the other hand, if both of his properties are less, he respects Mr Y very much).

To celebrate a new 2005 year, the administration of the club is planning to organize a party. However they are afraid that if two people who hate each other would simultaneouly attend the party, after a drink or two they would start a fight. So no two people who hate each other should be invited. On the other hand, to keep the club prestige at the apropriate level, administration wants to invite as many people as possible.

Being the only one among administration who is not afraid of touching a computer, you are to write a program which would find out whom to invite to the party.



This problem contains multiple test cases!



The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.



Input



The first line of the input file contains integer N - the number of members of the club. (2 <= N <= 100 000). Next N lines contain two numbers each - Si and Bi respectively (1 <= Si, Bi <= 109).



Output



On the first line of the output file print the maximum number of the people that can be invited to the party. On the second line output N integers - numbers of members to be invited in arbitrary order. If several solutions exist, output any one.



Sample Input



1

4
1 1
1 2
2 1
2 2



Sample Output



2
1 4



Author: Andrew Stankevich
Source: Andrew Stankevich‘s Contest #1

题意:如题。


思路:按照x递增y递减排序,然后求最长上升子序列。此题要求记录路径,lower_bound真是好东西。


AC代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stdlib.h>

using namespace std;

int dp[100005];
const int INF=1000000009;
int mark[100005];

struct Node{
    int x,y,id;
    bool operator < (const Node &a) const{
        return x<a.x||(x==a.x&&y>a.y);
    }
}p[100005];

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            int x,y;
            scanf("%d%d",&x,&y);
            p[i].x=x;
            p[i].y=y;
            p[i].id=i+1;
        }
        sort (p,p+n);
        fill(dp,dp+n,INF);
        int ans=0;
        for(int i=0;i<n;i++){
            int k=lower_bound(dp,dp+n,p[i].y)-dp;//返回大于或等于val的第一个元素位置;
            dp[k]=p[i].y;
            mark[i]=k;
            ans=max(ans,k);
        }
        printf("%d\n",ans+1);
        for(int i=n-1;i>=0;i--){
            if(mark[i]==ans){
                printf("%d",p[i].id);
                if(ans!=0) printf(" ");
                ans--;
            }
        }
        printf("\n");
        if(t!=0) printf("\n");
    }
    return 0;
}






ZOJ 2319 Beautiful People,布布扣,bubuko.com

ZOJ 2319 Beautiful People

标签:des   style   color   os   strong   io   for   art   

原文地址:http://blog.csdn.net/kimi_r_17/article/details/38172531

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!