码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1159 && POJ1458:Common Subsequence(LCS)

时间:2016-04-02 22:50:03      阅读:169      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.  The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 
Sample Input
abcfbc abfcab programming contest abcd mnp
 
Sample Output
4 2 0
 
 
//入门级问题,算法导论上很详细
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

char str1[1005],str2[1005];
int len1,len2;
int dp[1005][1005];

void LCS()
{
    len1=strlen(str1);
    len2=strlen(str2);
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=len1;i++)
    {
        for(int j=1;j<=len2;j++)
        {
            if(str1[i-1]==str2[j-1])
            dp[i][j]=dp[i-1][j-1]+1;
            else
            dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        }
    }
}

int main()
{
    while(cin>>str1>>str2)
    {
        LCS();
        cout<<dp[strlen(str1)][strlen(str2)]<<endl;
    }
    return 0;
}

 

HDU1159 && POJ1458:Common Subsequence(LCS)

标签:

原文地址:http://www.cnblogs.com/nefu929831238/p/5348476.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!