码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2533 Longest Ordered Subsequence(LIS)

时间:2016-04-02 22:51:28      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:

Description

A numeric sequence of ai is ordered ifa1 <a2 < ... < aN. Let the subsequence of the given numeric sequence (a1,a2, ..., aN) be any sequence (ai1,ai2, ..., aiK), where 1 <=i1 < i2 < ... < iK <=N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

//LIS比较好理解
//加油~

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

int main()
{
     int n,longest;
     int a[1005],dp[1005];
     while(scanf("%d",&n)!=-1)
     {
         longest=0;
         for(int i=0;i<n;i++)
         {
             scanf("%d",&a[i]);
             dp[i]=1;
         }
         for(int i=0;i<n;i++)
         {
             for(int j=0;j<i;j++)
             {
                 if(a[i]>a[j])
                 dp[i]=max(dp[j]+1,dp[i]);
             }
             longest=max(longest,dp[i]);
         }
         cout<<longest<<endl;
     }
     return 0;
}

 

poj 2533 Longest Ordered Subsequence(LIS)

标签:

原文地址:http://www.cnblogs.com/nefu929831238/p/5348380.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!