码迷,mamicode.com
首页 > 其他好文 > 详细

hdu-5655 CA Loves Stick(水题)

时间:2016-04-02 22:56:50      阅读:445      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:

CA Loves Stick

Time Limit: 2000/1000 MS (Java/Others)  

  Memory Limit: 262144/262144 K (Java/Others)


Problem Description
 
CA loves to play with sticks.
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
 

 

Input
 
First line contains T denoting the number of testcases.
T testcases follow. Each testcase contains four integers a,b,c,d in a line, denoting the length of sticks.
1T1000, 0a,b,c,d2631
 

 

Output
 
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
 

 

Sample Input
2
1 1 1 1
1 1 9 2
 

 

Sample Output
Yes
No
 
题意:
 
给4条边,问能不能形成四边形;
 
思路:
 
三条边的和大于第四边就能形成,主要是和会爆long long 所以要做差;还要注意是0的情况;
 
AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
long long a[5];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        for(int i=0;i<4;i++)
        {
            cin>>a[i];
        }
        sort(a,a+4);
        if(a[0]==0)cout<<"No"<<endl;
        else {
        if(a[3]-a[0]-a[1]<a[2])cout<<"Yes"<<"\n";
        else cout<<"No"<<"\n";
        }

    }
    return 0;
}

 

 

hdu-5655 CA Loves Stick(水题)

标签:

原文地址:http://www.cnblogs.com/zhangchengc919/p/5348409.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!