码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1379:DNA Sorting

时间:2016-04-03 11:49:22      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
One measure of ``unsortedness‘‘ in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC‘‘, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG‘‘ has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM‘‘ has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness‘‘, from ``most sorted‘‘ to ``least sorted‘‘. All the strings are of the same length.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
 
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
 
Output
Output the list of input strings, arranged from ``most sorted‘‘ to ``least sorted‘‘. If two or more strings are equally sorted, list them in the same order they are in the input file.
 
Sample Input
1 10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT
 
Sample Output
CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA
 
 
//水题一道,但对于我这种英语战五渣来说,就把题意理解错了 ( ▼-▼ )
 
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;

struct node
{
    char a[55];
    int num;
} DNA[200];


bool cmp(const node &a,const node &b)
{
    if(a.num<=b.num)
    return true;
    else return false;
}

int main()
{
    int t,len,n,c;
    cin>>t;
    while(t--)
    {
        cin>>len>>n;
        for(int i=0;i<n;i++)
        cin>>DNA[i].a;
        for(int i=0;i<n;i++)
        {
            DNA[i].num=0;
            c=0;
            for(int j=0;j<len;j++)
            {
                for(int m=j+1;m<len;m++)
                {
                    if(DNA[i].a[j]>DNA[i].a[m])
                    c++;
                }
            }
            DNA[i].num=c;
        }
        sort(DNA,DNA+n,cmp);
        for(int i=0;i<n;i++)
        cout<<DNA[i].a<<endl;
    }
    return 0;
}

 

 

HDU1379:DNA Sorting

标签:

原文地址:http://www.cnblogs.com/nefu929831238/p/5330138.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!