码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2689 Prime Distance

时间:2016-04-03 20:15:02      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:

Prime Distance

 

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

#include<cstdio>
#include<cstring>
#include<stack>
#include<queue>
#include<cmath>
#include<set>
#include<vector>
#include<iostream>
#include<map>
#include<string>
#include<algorithm>
using namespace std;
typedef double db;
typedef long long ll;
typedef unsigned long long ull;
const int N=50005;
bool vis[N];
bool notprime[N*20];
ll proprimes[N],len;
ll primes[N*20];
pair<ll,ll>minans,maxans;
void getprim()
{
    for(int i=2;i*i<N;i++)
        for(int j=i+i;j<N;j+=i)
            vis[j]=1;
    for(int i=2;i<N;i++)
        if(!vis[i])proprimes[len++]=i;
}
void solve(ll L,ll U)
{
    memset(notprime,0,sizeof(notprime));
    for(int i=0;i<len;i++)
    {
        ll b=L/proprimes[i];
        while(b*proprimes[i]<L||b<=1)b++;
        for(ll j=b*proprimes[i];j<=U;j+=proprimes[i])
            notprime[j-L]=1;
    }
    int t=0;
    if(L==1)notprime[0]=1;
    for(ll i=L;i<=U;i++)
    {
        if(!notprime[i-L])
            primes[t++]=i;
    }
    if(t<=1){puts("There are no adjacent primes.");return;}
    int mindist=1000005,maxdist=-1;
    for(int i=1;i<t;i++)
    {
        if(primes[i]-primes[i-1]>maxdist)
            maxdist=primes[i]-primes[i-1],maxans.first=primes[i-1],maxans.second=primes[i];
        if(primes[i]-primes[i-1]<mindist)
            mindist=primes[i]-primes[i-1],minans.first=primes[i-1],minans.second=primes[i];
    }
    printf("%lld,%lld are closest, %lld,%lld are most distant.\n",minans.first,minans.second,maxans.first,maxans.second);
}
int main()
{
    ll L,U;
    getprim();
    while(~scanf("%lld%lld",&L,&U))solve(L,U);
    return 0;
}

 

POJ 2689 Prime Distance

标签:

原文地址:http://www.cnblogs.com/homura/p/5350320.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!