码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4883 TIANKENG’s restaurant

时间:2014-07-28 16:03:23      阅读:250      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   os   io   for   art   div   


Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
11 6
 

Source

题意:求最少需要的椅子数

思路:贪心,开始的是+,结束的是-

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
const int maxn = 1000005;

struct E {
	int num;
	int e;
} brr[maxn];

int cmp(E a, E b) {
	if (a.e != b.e)
		return a.e < b.e;
	return a.num < b.num;
}

int main() {
	int t, n;
	scanf("%d", &t);
	while (t--) {
		int cnt = 0;
		int num, a, b, c, d;
		scanf("%d", &n);
		for (int i = 1; i <= n; i++) {
			scanf("%d %d:%d %d:%d", &num, &a, &b, &c, &d);
			brr[cnt].num = num;
			brr[cnt++].e = a*100+b;
			brr[cnt].num = -num;
			brr[cnt++].e = c*100+d;
		}
		sort(brr, brr+cnt, cmp);
		int ans = 0;
		int Max = -1;
		for (int i = 0; i < cnt; i++) {
			ans += brr[i].num;
			Max = max(ans, Max);
		}
		printf("%d\n", Max);
	}
	return 0;
}



HDU 4883 TIANKENG’s restaurant,布布扣,bubuko.com

HDU 4883 TIANKENG’s restaurant

标签:des   style   http   os   io   for   art   div   

原文地址:http://blog.csdn.net/u011345136/article/details/38227051

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!