码迷,mamicode.com
首页 > 其他好文 > 详细

HDUJ 1316 How Many Fibs?

时间:2014-07-28 16:08:53      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:hduj   java   

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4106    Accepted Submission(s): 1623


Problem Description
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.
 

Sample Input
10 100 1234567890 9876543210 0 0
 

Sample Output
5 4



import java.util.Scanner;
import java.math.BigInteger;


public class yhrtr {

	public static void main(String[] args) {
		Scanner cin = new Scanner (System.in);
		BigInteger s[] = new BigInteger[1010];
		s[1] = new BigInteger("1");
		s[2] = new BigInteger("2");
		for(int i=3;i<=1005;i++)
			s[i] = s[i-1].add(s[i-2]);
		
		BigInteger a,b,c;
		while(cin.hasNext())
		{
			a = cin.nextBigInteger();
			b = cin.nextBigInteger();
			if(a.compareTo(BigInteger.ZERO)==0 && b.compareTo(BigInteger.ZERO)==0)
				return ;
			if(a.compareTo(b)>0)
			{
				c = a;
				a = b;
				b = c;
			}
			
			int sum = 0;
			for(int i=1;i<=1005;i++)
			{
				if(s[i].compareTo(a)>=0 && s[i].compareTo(b)<=0)
					sum++;
			}
			System.out.println(sum);
		}
	}
}


HDUJ 1316 How Many Fibs?,布布扣,bubuko.com

HDUJ 1316 How Many Fibs?

标签:hduj   java   

原文地址:http://blog.csdn.net/hyccfy/article/details/38226503

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!