码迷,mamicode.com
首页 > 其他好文 > 详细

POJ-2104-K-th Number(函数式线段树)

时间:2014-07-28 16:14:11      阅读:257      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   for   art   

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion


思路:离散化,插入,查询。详见代码。


#include <cstdio>
#include <algorithm>
using namespace std;

struct S{
int val,id,pos;
}node[100005];

bool cmpval(struct S a,struct S b)
{
    return a.val<b.val;
}

bool cmpid(struct S a,struct S b)
{
    return a.id<b.id;
}

int T[100005],ls[4000000],rs[4000000],vv[100005],cnum[4000000],nodenum,cnt,n,m;

void insert(int s,int e,int pos,int pre,int &x)
{
    x=++nodenum;

    ls[x]=ls[pre];
    rs[x]=rs[pre];

    cnum[x]=cnum[pre]+1;

    if(s!=e)
    {
        int mid=(s+e)>>1;

        if(pos<=mid) insert(s,mid,pos,ls[pre],ls[x]);
        else insert(mid+1,e,pos,rs[pre],rs[x]);
    }

}

int query(int a,int b,int s,int e,int k)
{
    if(s==e) return vv[s];
    else
    {
        int mid=(s+e)>>1;

        if(cnum[ls[b]]-cnum[ls[a]]>=k) return query(ls[a],ls[b],s,mid,k);//跟第b棵树的左子树和第a棵树的左子树的差比较
        else return query(rs[a],rs[b],mid+1,e,k-cnum[ls[b]]+cnum[ls[a]]);
    }
}

int main()
{
    int i,a,b,k;

    while(~scanf("%d%d",&n,&m))
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&node[i].val);
            node[i].id=i;

            vv[i]=node[i].val;
        }

        sort(vv+1,vv+n+1);
        cnt=unique(vv+1,vv+n+1)-vv-1;//去重

        sort(node+1,node+n+1,cmpval);

        int p=1;

        for(i=1;i<=n;i++)//离散化
        {
            if(node[i].val!=vv[p]) p++;

            node[i].pos=p;
        }

        sort(node+1,node+n+1,cmpid);

        T[0]=ls[0]=rs[0]=cnum[0]=nodenum=0;

        for(i=1;i<=n;i++) insert(1,cnt,node[i].pos,T[i-1],T[i]);

        while(m--)
        {
            scanf("%d%d%d",&a,&b,&k);

            printf("%d\n",query(T[a-1],T[b],1,cnt,k));
        }
    }
}


POJ-2104-K-th Number(函数式线段树),布布扣,bubuko.com

POJ-2104-K-th Number(函数式线段树)

标签:des   style   http   color   os   io   for   art   

原文地址:http://blog.csdn.net/faithdmc/article/details/38225389

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!