码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1442

时间:2014-07-28 16:14:14      阅读:249      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   strong   io   for   

Black Box
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 7177   Accepted: 2916

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

Source

Northeastern Europe 1996

AC代码:看代码解释就行了

#include<iostream>
#include<queue>
#include<algorithm>
#include<stdio.h>
using namespace std;
int a[30010];
priority_queue <int> qu1;          //优先队列由大到小保存前i小的数 
priority_queue <int,vector<int>,greater<int> > qu2;         //优先队列由小到大保存剩下的数 
int main(){
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        while(!qu1.empty())
            qu1.pop();
        while(!qu2.empty())
            qu2.pop();
        int t=0;
        for(int i=1;i<=m;i++){
            int x; scanf("%d",&x);
            while(t<x)
                qu1.push(a[t++]);
            while(qu1.size()>i){
                    qu2.push(qu1.top());
                    qu1.pop();
            }
            while(qu1.size()<i){
                qu1.push(qu2.top());
                qu2.pop();
            }
            while(!qu2.empty() && qu1.top()>qu2.top()){      //使qu1的所有数都比qu2的数小 
                    qu2.push(qu1.top());
                    qu1.pop();
                    qu1.push(qu2.top());
                    qu2.pop();
            }
            printf("%d\n",qu1.top());
        }
    }
    return 0;
}


poj 1442,布布扣,bubuko.com

poj 1442

标签:des   style   http   color   os   strong   io   for   

原文地址:http://blog.csdn.net/my_acm/article/details/38225433

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!