码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1837 Balance (DP)

时间:2014-07-28 16:14:46      阅读:244      评论:0      收藏:0      [点我收藏+]

标签:poj   dp   

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm‘s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
? the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
? the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-‘ for the left arm and ‘+‘ for the right arm);
? on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights‘ values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2


题意:一个天平上有c个位置,在平衡点左边的位置为负数,右边为正数。现在有g个砝码,问用这些砝码可以使天平平衡的方法总数。砝码可以不用完。

设dp[i][j]为第i个砝码放进去之后,平衡点为j时的方法数。(-15*20*25<=j<=15*20*25) 当j==7500时就是所有重量为25的钩码都在最右端15cm的情况。

为了方便j的计算,可以设置7500为平衡点,那么j的范围变成了(0~15000)。

首先一个砝码都没有时,dp[0][7500]=1,因为一个都不放,在平衡点肯定有一种方法就是不放。

dp[i][j+w[i]*pos[k]] += dp[i-1][j] ; (对于所有位置k,放上第i个砝码时对应的dp[][]值  都要加上前i-1个砝码时对应的dp[][]值 , 且仅为dp[i-1][j]的值不为0时,加起来才有意义)

dp[i-1][j]的值不为0,说明dp[i-1][j]这个状态是由可以被计算的推来,最初可以被计算的也只有dp[0][7500],因此,dp[i][j-1]的j状态,不必担心j+w[i]*pos[k]会出现下标为负的情况,因为最初的j一定是7500.

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
typedef long long LL;
const int MAX=0x3f3f3f3f;
int c,g,dp[21][15005],pos[25],w[25];
int main()
{
    scanf("%d%d",&c,&g);
    for(int i=1;i<=c;i++) scanf("%d",&pos[i]);
    for(int i=1;i<=g;i++) scanf("%d",&w[i]);
    dp[0][7500]=1;
    for(int i=1;i<=g;i++)
        for(int j=0;j<=15000;j++) if( dp[i-1][j] )  // dp[i-1][j]不为0说明已经被计算过,以下的j不会越过0~15000,而且dp[i-1][j]如果为0,加的没意义。
            for(int k=1;k<=c;k++)
                dp[i][ j+w[i]*pos[k] ] += dp[i-1][j];
    printf("%d\n",dp[g][7500]);

    return 0;
}





POJ 1837 Balance (DP),布布扣,bubuko.com

POJ 1837 Balance (DP)

标签:poj   dp   

原文地址:http://blog.csdn.net/u013923947/article/details/38225457

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!