码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 4883 TIANKENG’s restaurant

时间:2014-07-28 16:28:13      阅读:260      评论:0      收藏:0      [点我收藏+]

标签:hdoj   bestcoder   rmq   zkw线段树   

题目:

TIANKENG’s restaurant

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 249    Accepted Submission(s): 125


Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
11 6
 

解题思路:

转换为RMQ问题,1天24h,1440min;a[i]表示第i分钟的人数,n表示时间[t1,t2)之间来的人数,对这个区间内的a[i]+n,最后求的是a[i]的最大值。

解法1:模拟


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

#define clr(a) memset(a, 0, sizeof(a))
#define rep(i,s,t) for(int i = s; i <= t; ++i)
#define per(i,s,t) for(int i = s; i >= t; --i)

const int MAXN = 1450;
int t, n, a[MAXN];

int main()
{
    scanf("%d", &t);
    while(t--)
    {
        clr(a);
        scanf("%d", &n);
        int num, h1, m1, h2, m2;
        rep(i,0,n-1)
        {
            scanf("%d%d:%d%d:%d", &num, &h1, &m1, &h2, &m2);
            int s1 = h1 * 60 + m1, s2 = h2 * 60 + m2;
            rep(j,s1,s2-1) a[j] += num;
        }
        int ans = -1;
        rep(i,0,MAXN-1) ans = max(ans,a[i]);
        printf("%d\n", ans);
    }
    return 0;
}

解法2:线段树(ZKW)

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

#define clr(a) memset(a, 0, sizeof(a))
#define rep(i,s,t) for(int i = s; i <= t; ++i)
#define per(i,s,t) for(int i = s, i >= t; --i)

const int M = 1<<11, MAXN = 1440;
int icase, n, a[M << 1];


void Add_x(int s, int t, int x)
{
    int b = 0;
    for(s=s+M-1, t=t+M+1; s^t^1; s>>=1, t>>=1)
    {
        if(~s&1) a[s^1] += x;
        if( t&1) a[t^1] += x;
        b = max(a[s], a[s^1]), a[s]-=b, a[s^1]-=b, a[s>>1]+=b;
        b = max(a[t], a[t^1]), a[t]-=b, a[t^1]-=b, a[t>>1]+=b;
      //  printf("%d %d %d %d\n", s, t, a[s^1], a[t^1]);
    }
    for( ; s > 1; s>>=1)
    b = max(a[s], a[s^1]), a[s]-=b, a[s^1]-=b, a[s>>1]+=b;
}

int Max(int s, int t)
{
    int lans = 0, rans = 0, ans = 0;
    for(s=s+M-1,t=t+M+1; s^t^1; s>>=1, t>>=1)
    {
        lans+=a[s], rans+=a[t];
        if(~s&1) lans = max(lans, a[s^1]);
        if( t&1) rans = max(rans, a[t^1]);
     //   printf("%d %d %d %d\n", s, t, lans, rans);
    }
    ans = max(lans+a[s], rans+a[t]);
    while(s>1) ans+=a[s>>=1];
    return ans;
}

void show()
{
    for(int i = 0; i < M; i++)
        printf("%d ", a[i]);
    printf("\n");
}

int main()
{
    scanf("%d", &icase);
    while(icase--)
    {
        scanf("%d", &n); clr(a);
        int num, h1, m1, h2, m2;
        for(int i = 0; i < n; ++i)
        {
            scanf("%d%d:%d%d:%d", &num, &h1, &m1, &h2, &m2);
            int s1 = h1 * 60 + m1, s2 = h2 * 60 + m2;
            Add_x(1+s1, s2, num);
        }
    //    show();
        printf("%d\n", Max(1,1440));
    }
    return 0;
}


HDOJ 4883 TIANKENG’s restaurant,布布扣,bubuko.com

HDOJ 4883 TIANKENG’s restaurant

标签:hdoj   bestcoder   rmq   zkw线段树   

原文地址:http://blog.csdn.net/u010084308/article/details/38206323

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!