码迷,mamicode.com
首页 > 其他好文 > 详细

uva10327 - Flip Sort

时间:2014-07-28 23:53:34      阅读:260      评论:0      收藏:0      [点我收藏+]

标签:style   blog   color   os   io   for   art   cti   

Flip Sort

Sorting in computer science is an important part. Almost every problem can be solved effeciently if sorted data are found. There are some excellent sorting algorithm which has already acheived the lower bound nlgn. In this problem we will also discuss about a new sorting approach. In this approach only one operation ( Flip ) is available and that is you can exchange two adjacent terms. If you think a while, you will see that it is always possible to sort a set of numbers in this way.

The Problem

A set of integers will be given. Now using the above approach we want to sort the numbers in ascending order. You have to find out the minimum number of flips required. Such as to sort "1 2 3" we need no flip operation whether to sort "2 3 1" we need at least 2 flip operations.

The Input

The input will start with a positive integer N ( N<=1000 ). In next few lines there will be N integers. Input will be terminated by EOF.

The Output

For each data set print "Minimum exchange operations : M" where M is the minimum flip operations required to perform sorting. Use a seperate line for each case.

Sample Input

3 
1 2 3
3
2 3 1

Sample Output

Minimum exchange operations : 0
Minimum exchange operations : 2

 

 

相邻交互排序最少交换次数 是 逆序对

冒泡排序的交换次数是逆序对

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=1001;
int a[maxn];
int n;

//两重循环进行枚举 计算逆序对
int solve()
{
    int cnt=0;
    for(int i=0;i<n-1;i++)
        for(int j=i+1;j<n;j++)
            if(a[i]>a[j])
                cnt++;
    return cnt;
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("./uva10327.in", "r", stdin);
#endif
    while(scanf("%d", &n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d", a+i);
        }
        printf("Minimum exchange operations : %d\n", solve());
    }
    return 0;
}

uva10327 - Flip Sort,布布扣,bubuko.com

uva10327 - Flip Sort

标签:style   blog   color   os   io   for   art   cti   

原文地址:http://www.cnblogs.com/cute/p/3873339.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!