码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1005 Number Sequence

时间:2016-04-09 20:28:05      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

 

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 3 1 2 10 0 0 0
 

 

Sample Output
2 5
 
 
这题题目给定公式,明确告诉我们f[n] = (A * f[n - 1] + B * f[n - 2]) mod 7。数据范围A,B ≤ 1000,n ≤ 100000000,n 的数值有一亿,暴力肯定是过不了,所以来分析公式。对于每个f[n]的取值都在0到6之间,所以在A,B给定的情况下,实际上只有7 * 7 = 49种情况。在打表的过程中,发现出现了循环串,那么实际上任务就变成了找到循环串。
 
 下面贴出代码:

#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#define N 101


int f[N];

int main()
{
    int A, B, n;
    f[1] = 1;
    f[2] = 1;
    while (scanf("%d%d%d", &A, &B, &n) == 3 && n){
        int begin, end;
        bool flag = false;
        for (int i = 3; i <= n && !flag; i++){
            f[i] = (A * f[i - 1] + B * f[i - 2]) % 7;
            for (int j = 2; j <= i - 1; j++){
                if (f[i] == f[j] && f[i - 1] == f[j - 1]){
                    begin = j, end = i;
                    flag = true;
                    break;
                }
            }
        }
        if (flag)
            printf("%d\n", f[begin + (n - end) % (end - begin)]);
        else
            printf("%d\n", f[n]);
    }
    //system("pause");
    return 0;
}

 

hdu 1005 Number Sequence

标签:

原文地址:http://www.cnblogs.com/Lynnray/p/5372323.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!