码迷,mamicode.com
首页 > 其他好文 > 详细

PKU OJ 1002 487-3279

时间:2016-04-10 21:33:27      阅读:357      评论:0      收藏:0      [点我收藏+]

标签:

PKU OJ 1002 487-3279

?

487-3279

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino‘s by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their "three tens" number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

?

No duplicates.

Sample Input

12

4873279

ITS-EASY

888-4567

3-10-10-10

888-GLOP

TUT-GLOP

967-11-11

310-GINO

F101010

888-1200

-4-8-7-3-2-7-9-

487-3279

Sample Output

310-1010 2

487-3279 4

888-4567 3

Source

East Central North America 1999

?

(1)其实我的思路没啥错的,将输入的字符串转换为整数int,存在数组中,因为号码之后七位数所以这样考虑是对的,而且之后看到别人的答案大部分都觉得字符串排序处理起来比较慢;

(2)在排序这块想到的是用比较快的排序来算,从网上摘抄了一段快速排序的源码来用,结果还是超时了,于是用C++里面自带的一个qsort来排序,还写了一个比较函数;

(3)之前有个错误一直没有发现,导致多次提交心里很是蛋疼,你说做OJ这种东西,明明感觉是到处都对,感觉练到手就好了,但是还是希望最后能够AC的。一次次提交失败让我很是不爽啊;心一横去网上找测试数据;居然找到了;

(4)找到了然后又要把数据一个个读出来,又是一番百度;

(5)结果通过对比测试的数据,发现数字和大写字母的对应搞错了一个,结果改了一个符号就AC,唉;

(5)OJ还学会了不少新词呢,什么WARE还有AC的,当然大家是都想要AC的啦;

(6)很多人呢这题也没有通过,然后就是贴代码,我也想贴啊,让人绑我看看那儿错了,但是大牛们谁会帮你看代码呢,有病还是自己治,这里捅捅,那里捅捅说不定就成了呢;

(7)主要是为了学C++,各种强行面向对象,有啥高级货都拿来试试,关键是还没学到STL和更高级的东东,有所限制。

?

?

Source Code

#include <iostream>

#include <stdio.h>

using namespace std;

?

class Phone {

????int table[100100];

????int total;

????int collect[100100];

????int flag;

public:

????Phone(int T) {

????????total = T;

????????for(int i=0; i<T; i++)????//将表初始化

????????????table[i]=0;

????}

????void TurnOver(char* s,int n) {

????????int p=0, pow=1000000,flag=0,m;

????????for(int i=0; i<40; i++)

????????{

????????????if(flag >= 7)

????????????????break;

????????????switch (s[i]) {

????????????????case ‘0‘: {m=0;p=1;break;}

????????????????case ‘1‘: {m=1;p=1;break;}

????????????????case ‘2‘: case ‘A‘: case ‘B‘: case ‘C‘: {m=2;p=1;break;}

????????????????case ‘3‘: case ‘D‘: case ‘E‘: case ‘F‘: {m=3;p=1;break;}

????????????????case ‘4‘: case ‘G‘: case ‘H‘: case ‘I‘: {m=4;p=1;break;}

????????????????case ‘5‘: case ‘J‘: case ‘K‘: case ‘L‘: {m=5;p=1;break;}

????????????????case ‘6‘: case ‘M‘: case ‘N‘: case ‘O‘: {m=6;p=1;break;}

????????????????case ‘7‘: case ‘P‘: case ‘R‘: case ‘S‘: {m=7;p=1;break;}

????????????????case ‘8‘: case ‘T‘: case ‘U‘: case ‘V‘: {m=8;p=1;break;}

????????????????case ‘9‘: case ‘X‘: case ‘Y‘: case ‘W‘: {m=9;p=1;break;}

????????????}

????????????if(p==1) {

????????????????flag++;

????????????????table[n] += m*pow;

????????????????pow /= 10;

????????????????p=0;

????????????}

????????}

????}

????void printPhone() {

????????int a;

????????int pow;

????????int temp;

????????if(flag==0) {

????????????cout << "No duplicates." << endl;

????????????return;

????????}

????????for(int i=0; i<total; i++) {

????????????if(collect[i]>=1) {

????????????????temp = table[i];

????????????????//这里输出电话号码时,注意不能动table

????????????????pow = 1000000;

????????????????for(int j=0; j<7; j++) {

????????????????????a = temp/pow;

????????????????????temp = temp - a*pow;

????????????????????pow = pow/10;

????????????????????cout << a;

????????????????????if(j==2)

????????????????????????cout << "-";

????????????????}

????????????????cout << " " << collect[i]+1 << endl;

????????????}

????????}

????}

????

????void quickSort(int s[], int l, int r) {

????????if(l<r) {

????????????int i=l, j=r, x=s[l];

????????????while (i<j) {

????????????????while(i<j && s[j]>=x)

????????????????????j--;

????????????????if(i<j)

????????????????????s[i++] = s[j];

????????????????while(i<j && s[i]<x)

????????????????????i++;

????????????????if(i<j)

????????????????????s[j--] = s[i];

????????????}

????????????s[i]=x;

????????????quickSort(s, l, i-1);

????????????quickSort(s, i+1, r);????????????

????????}

????}

????void Sort() {

????????quickSort(table,0,total-1);

????}

????void dupSelect() {

????????int tmp = table[0],pos=0;

????????flag=0;

????????for(int i=0; i<total; i++)

????????????collect[i]=0;

????????for(int i=1; i<total; i++) {

????????????if (tmp == table[i]) {

????????????????????collect[pos]++;

????????????????????flag=1;

????????????}

????????????else {

????????????????tmp = table[i];

????????????????pos=i;

????????????}

????????}

????}????

};

?

int main(void) {

????int T;

????char s[40];

????cin >> T;

????getchar();

????Phone a(T);

????for(int i=0; i<T; i++) {

????????gets(s);

????????a.TurnOver(s, i);

????}

????a.Sort();

????a.dupSelect();

????a.printPhone();

}

PKU OJ 1002 487-3279

标签:

原文地址:http://www.cnblogs.com/tuhooo/p/5375190.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!