Big Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5268 Accepted Submission(s): 3663
Problem Description
As we know, Big Number is always troublesome. But it‘s really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
Output
For each test case, you have to ouput the result of A mod B.
Sample Input
2 3
12 7
152455856554521 3250
Sample Output
Author
Ignatius.L
Source
Recommend
Eddy | We have carefully selected several similar problems for you:
1215 1211 1214 1213 1695
import java.io.*;
import java.math.BigInteger;
import java.util.*;
public class Main
{
public static void main(String[] args)
{
// TODO Auto-generated method stub
Scanner input = new Scanner(System.in);
while (input.hasNext())
{
BigInteger A = input.nextBigInteger();
BigInteger B = input.nextBigInteger();
BigInteger N = A.remainder(B);
System.out.println(N);
}
}
}