码迷,mamicode.com
首页 > 其他好文 > 详细

treap树---Double Queue

时间:2016-04-12 22:17:34      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:

HDU   1908

Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0 The system needs to stop serving
KP Add client K to the waiting list with priority P
2 Serve the client with the highest priority and drop him or her from the waiting list
3 Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifierK is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0

Sample Output

0
20
30
10
0

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
struct data
{
    int l,r,v,vo;
    int rnd;
}tr[1100000];
int size,root,ans2;///定义全局整型变量默认初值为0;

void rturn(int &k)
{
    int t=tr[k].l;
    tr[k].l=tr[t].r;
    tr[t].r=k;
    k=t;
}

void lturn(int &k)
{
    int t=tr[k].r;
    tr[k].r=tr[t].l;
    tr[t].l=k;
    k=t;
}

void insert(int &k,int x,int xo)
{
    if(k==0)
    {
        size++;///记录已经使用的结构体数目;
        k=size;
        tr[k].v=x;
        tr[k].vo=xo;
        tr[k].rnd=rand();
        return;
    }
    if(x>tr[k].v)
    {
        insert(tr[k].r,x,xo);
        if(tr[tr[k].r].rnd<tr[k].rnd)
            lturn(k);
    }
    else
    {
        insert(tr[k].l,x,xo);
        if(tr[tr[k].l].rnd<tr[k].rnd)
            rturn(k);
    }
}

void search_min(int &k)///最小值一定在最左的节点上;
{
    if(tr[k].l==0)
    {
        ans2=tr[k].vo;
        k=tr[k].r;
        return ;
    }
     search_min(tr[k].l);
}

void search_max(int &k)///最大值一定在最右的节点上;
{
    if(tr[k].r==0)
    {
        ans2=tr[k].vo;
        k=tr[k].l;
        return ;
    }
     search_max(tr[k].r);
}

int main()
{
    int x,k,p;
    while(scanf("%d",&x)!=EOF&&x)
    {
        ans2=0;
        if(x==1)
        {
            scanf("%d%d",&k,&p);
            insert(root,p,k);
        }
        else if(x==2)
        {
            if(root)
            search_max(root);
            printf("%d\n",ans2);
        }
        else if(x==3)
        {
            if(root)
            search_min(root);
            printf("%d\n",ans2);
        }
    }
    return 0;
}

 

treap树---Double Queue

标签:

原文地址:http://www.cnblogs.com/chen9510/p/5384601.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!