码迷,mamicode.com
首页 > 其他好文 > 详细

WHU1606 Funny Sheep 思维

时间:2016-04-13 00:13:56      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:

Description

There are N+1 rows and M+1 columns fence with N*M grids on the grassland. Each grid has a sheep. In order to let the sheep together, we need to dismantle the fence. Every time you can remove a row or a column of fences. What’s the least number of times to reach the goal? 

Input
There are multiple test cases.
The first line of each case contains two integers N and M. (1≤N,M≤1000)
Output
For each case, output the answer in a line.
Sample Input
1 2
2 2
Sample Output
1
2
题目大意:一个N*M的网格,每个格子里都有一头羊,现在要把所有羊聚集在一起。。。要通过拆网格,每次拆一行或者一列,问最小次数。
思路:可以拆外面的墙,只要找行与列最小的。。。玛德智障
#include <stdio.h>
int main()
{
int n, m;
while(~scanf("%d%d", &m, &n)){
if(m==n&&n==1)
printf("0\n");
else{
m = m>n?n+1:m+1;
printf("%d\n", m-1);
}
}
return 0;
}

 

WHU1606 Funny Sheep 思维

标签:

原文地址:http://www.cnblogs.com/Noevon/p/5385091.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!